Platform Compatibility Matrix - HVR 5.3.0

This compatibility matrix provides information about the operating systems and DBMSs that are supported by HVR 5.3.0 release.

For information regarding Capture, Hub, Integrate and other features supported by HVR, refer to the respective location class requirements section or the release notes.

Blank cell indicates "not supported".

HVR Platform Name

aix_6.1-powerpc-64bit

linux_glibc2.5-x64-64bit

macos-x64-64bit

solaris_10-sparcv9-64bit

solaris_10-x64-64bit

windows-x64-64bit

Operating System

AIX: 6.1, 7.1, 7.2

Linux (x86-64 bit) based on GLIBC 2.5 and higher. This includes:

  • Red Hat Enterprise Linux Server: 5.x, 6.x, 7.x
  • SUSE Linux Enterprise Server: 10.x, 11.x, 12.x
  • Machines imaged from Amazon Linux AMI or Amazon Linux 2

macOS Sierra: 10.12.x

Solaris for SPARC: 9, 10, 11.x

Solaris for Intel/AMD: 10.x, 11.x

Windows (PC): 8, 10
Windows Server: 2003, 2008, 2012 R2, 2016

HVR User Interface

CLI

GUI (using X client), CLI

GUI, CLI

CLI

CLI

GUI, CLI

DB2 for i

7.1, 7.2

7.1, 7.2

DB2 for LUW


10.5

10.5

File

Local, FTP/FTPS, SFTP

Local, FTP/FTPS, SFTP

Local, FTP/FTPS, SFTP

Local, FTP/FTPS, SFTP

Local, FTP/FTPS, SFTP

Local, FTP/FTPS, SFTP

Greenplum

4.0, 4.2, 4.3, 5.54, 5.104

4.0, 4.2, 4.3, 5.54, 5.104

HANA

1.0 SPS: 11, 12
2.0 SPS: 00, 013, 023

1.0 SPS: 11, 12
2.0 SPS: 00, 013 , 023

HDFS

2.2.0 and higher

2.2.0 and higher

Hive ACID

1.2.x, 2.1.x, 2.2.x1, 2.3.x1

1.2.x, 2.1.x, 2.2.x1, 2.3.x1

Ingres /
Vector /
Vector(H)

Ingres: 9.1, 9.2, 9.3, 10.0, 10.1, 10.2

Ingres: 9.1, 9.2, 9.3, 10.0, 10.1, 10.2, 11.0
Vector: 2.x, 3.0
Vector(H): 4.x

Ingres: 9.1, 9.2, 9.3, 10.0, 10.1, 10.2, 11.0

Ingres: 10.0, 10.1, 10.2, 11.0
Vector: 2.x, 3.0
Vector(H): 4.x

Kafka

0.8 and higher

0.8 and higher

MySQL /
MariaDB /
Aurora MySQL

MySQL: 5.6, 5.7
MariaDB: 10.0, 10.1, 10.2 
Aurora MySQL: 5.6, 5.7

MySQL: 5.6, 5.7
MariaDB: 10.0, 10.1, 10.2 
Aurora MySQL: 5.6, 5.7

Oracle

10.2, 11.2, 12.1

11.1, 11.2, 12.1, 12.23, Exadata

10.2, 11.1, 11.2, 12.1

11.2, 12.1

10.2, 11.1, 11.2, 12.1, 12.23

PostgreSQL /
Aurora PostgreSQL

PostgreSQL: 8.x, 9.x, 102
Aurora PostgreSQL: 1.0, 1.1

PostgreSQL: 9.x, 102
Aurora PostgreSQL: 1.0, 1.1

Redshift

Supported

Supported

S3

Supported

Supported

Supported

Supported

Supported

Supported

Salesforce

Supported

Supported

Supported

Supported

Supported

Snowflake

Supported

Supported

SQL Server /
Azure SQL Database /
Azure Synapse Analytics

SQL Server: 2008, 2012, 2014, 2016, 20174
Azure SQL Database - Supported 
Azure Synapse Analytics - Supported

Teradata

15.x, 16.x

15.x, 16.x

15.x, 16.x

WebDAV / Sharepoint

2010, Online

2010, Online

2010, Online

2010, Online

2010, Online

2010, Online

1  - Supported since HVR 5.3.0/1

2  - Supported since HVR 5.3.0/4

3  - Supported since HVR 5.3.0/7

4  - Supported since HVR 5.3.0/9